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INTRODUCTION
The Spindle Error Analyzer System is a hardware and software package for measuring and
analyzing the accuracy of spindles on machine tools, hard-disk drives etc.

Fundamental Concepts

SEA uses noncontact, capacitive sensing to measure error motions as changes in position of
precision master targets installed and rotating in the machine spindle. The sensors have a typical
range of 250µm with a resolution of 15nm RMS. Actual values may vary depending on the specifics
of the system ordered.

The measurements are collected and analyzed by the SEA software. The results of the active
measurement or archived measurement file are presented on polar or linear plots with calculated
values of error motion measurements.

Tests Performed by SEA

SEA performs the following tests as described in ISO and ANSI/ASME standards:

• Radial rotating sensitive direction
• Radial fixed sensitive direction
• Tilt fixed sensitive direction
• Axial error motion
• Thermal stability
• Temperature variation error
• Shift vs. RPM

Additional Capabilities of SEA

• FFT Analysis
• Oscilloscope display
• Analog meter display
• Donaldson reversal test
• Automated Test Sequencing

https://www.lionprecision.com/two-year-warranty/
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Standards and References

• ANSI/ASME Standard B5.54-2005, Methods for Performance Evaluation of CNC Machining
Centers

• ISO230 Part 3 (2001), Test Conditions for Metal Cutting Machine Tools, Evaluation of Thermal
Effects

• ISO230 Part 7 (2005), Geometric Accuracy of Axes of Rotation
• ANSI/ASME B5.57-2012, Methods for Performance Evaluation of CNC Turning Centers
• ANSI/ASME B89.3.4-2010, Axes of Rotation, Methods for specifying and testing

Assistance

For assistance with the installation and operation of the SEA 8 system, please visit our web site
at: www.spindleanalysis.com or contact us at:
Lion Precision
7166 4th St. N. Oakdale, MN 55128
support@lionprecision.com
651-484-6544
www.lionprecision.com
www.spindleanalysis.com

https://www.lionprecision.com/two-year-warranty/
https://www.lionprecision.com


www.lionprecision.com/two-year-warranty/ Document No. M016-0650

6Oakdale, MN, USA www.lionprecision.com 651-484-6544

Parts ID

Drawings below identify some of the mechanical components included in the SEA system.

5-Probe Nest Adaptor

3-Probe Nest

Probe Nest Lathe Adaptor

20mm,dual-surface
gage pin

1/2" Master Ball
Target

1" Master Ball
Target

Dual 1" Master Ball
Target
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INSTALLATION
SEA Software

Install all software before installing the data acquisition device. The SEA software installation
includes installation of all required National Instruments driver software.

Do not install any software from National Instruments disks included with the National
Instruments data acquisition hardware.

Minimum Requirements

• Windows XP, Windows Vista, Windows 7 (32 or 64 bit)
• 1 GB Ram (desktop), 1.5 GB Ram (laptop); 1 GB Free Disk Space (minimum)
• 1 GHz Processor
• 1 Available USB port; 1024 x 768 Minimum Screen Resolution

Procedure

The SEA installation program installs all necessary hardware drivers. Do not install National
Instruments software separately. The SEA program is installed in the PROGRAM FILES\SEA8
directory on your hard disk. If you install the SEA software a second time using the same
subdirectory, you will be prompted to confirm the overwrite of the previous installation.

To use the SEA DVD:

1. Insert the DVD and wait for the autorun program to load the welcome screen, then select
install.

2. If Autorun is disabled on your computer or if the DVD fails to autorun for any reason, click on
the “Computer” or “My Computer” icon. Then choose the DVD drive. Double click on the
program Install.exe.

3. Follow the directions of the installation programs:
4. Once the installation has copied all files from the installation disk, restart the computer.
5. After restarting, run the program by selecting the icon on the desktop, or by selecting Start >

Programs > SEA8.

The installation DVD also contains demo data files and other valuable documents related to spindle
measurement and improving machine part quality.

CAUTION

Data Acquisition Hardware

SEA requires a National Instruments USB-6251 Data Acquisition System.

All National Instruments software was installed with the SEA8 installation. Do not install any
National Instruments software from National Instruments CD/DVDs.

Security Key (Dongle)

If an Elite Series sensor system is labeled on the rear panel as “SEA System” you will not require
a security key. If you are not using an Elite Series (tan colored) or it is not labeled as an SEA
system, then the security key must be attached to a USB port on the computer to perform
measurements and collect data. The security key is not required to view or print saved data files.

Probes and Targets

See Mounting Probes and Targets section (page 18).
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Select Mode of Operation

When the program is launched (Start > SEA8 > SEA8), a dialog box appears requiring mode of
operation selections in four categories. Selections are as follows:

Measurement System Model

Elite Series - sensors provide TEDS (transducer electronic data sheets) information to the SEA
system.

CB-7 - Older style sensors do not provide TEDS and require the installation of VTEDS files (p. 12).

Use the photographs to help you select your measurement system. If the software key is not
connected to the computer, these buttons will be grayed out.

Select DAQ Source

Select DAQ Device (DEV1, DEV2)

The first time the program is run, you must select the source of DAQ information. Normally, there
is only one to choose from. The installed DAQ devices are listed as: DEV1, DEV2…. After selecting
a device, a description of the device will be displayed.

If only viewing or printing data (there is no DAQ device), select None.

View Files Only

View Files Only – This mode only produces static displays of files loaded for viewing.

Setting the Acrobat Path

Adobe Acrobat is used for viewing the pdf manual from the Help menu. SEA must know the path
to the Acrobat application.

This path is entered in the Main Menu > Configuration > Show Configuration > General screen.

The following is a typical path to the file, but it may be different on your computer:

Acrobat: C:\Program Files\Adobe\Reader 10.0\Reader\
Each new version of Acrobat will be placed in a new directory. If you install a new version of
Acrobat, this path must be modified.
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Basic Navigation

The SEA software uses several simple conventions that make the software easy to use.

• Menus display lists of selectable options.
• Buttons execute or gain access to features.
• Panels display fields of information.
Quadrant Displays

SEA starts with four different display panels in
four quadrants on your screen. Each quadrant
displays a selected view of the current data. The
current data may be live data from the sensors,
saved data from a previous measurement, or
simulated data for training and experimentation.

Each quadrant has a menu bar which begins
with Display. Use the display menu to select
which panel to display in that quadrant.

Logo Screen (Information Quadrant)

Screen prints are often used to document spindle tests. It is helpful to have test information
displayed on the screen when the screen is printed.

To display an information quadrant, select Display > Logo Screen in a quadrant.

Click in the text box to enter text. To change the displayed image, select View > Select Graphic
from logo screen’s tool bar.

Maximizing to Full Screen

Initially, each display uses one quarter of the screen (quadrant). Select View > Maximum Size
to fill the entire screen, or double click the right mouse button over the display to be maximized.

Minimizing Display to a Quadrant

Select View > Normal Size to return a maximized display to its quadrant, or double click the right
mouse button over the display.

Choosing a Language

To select a language other than English:

1. In any quadrant, select Display > Configuration Displays > General Configuration
2. Select the desired language from the Language drop down menu
3. Exit and restart the SEA Software
Language choice is remembered between sessions.
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SEA CONFIGURATION
SEA software must be properly configured for proper operation. There are different types of
configuration information:

• Indicators: These display information acquired from the system or calculated from other
fields.

• Automatic Inputs: These are required input settings which are automatically acquired from
the system.

• Manual Inputs: These may be required or optional input settings that must be manually
entered by the user.

Configuration settings can be saved with Configuration > Save Configuration in the main menu
bar.

The complete configuration consists of data from several different configuration windows. Access
the configuration windows through Main Menu > Configuration or individual quadrant Display >
Configuration > [Selected Configuration Window].

General Configuration

DAQ Configuration

DAQ configuration settings determine the operation of the data acquisition board and are critical
to the operation of the system. This panel displays the RPM Range possible with the current
settings and is updated when the settings are changed. Settings in Analysis Configuration also
affect the RPM Range.

Field Type Notes

Language Required Manual Input

PDF Viewer Optional Manual Input Path to Adobe Acrobat. Must be entered
correctly to view the on-screen manual.

Display Units Required Manual Input

Date Format Required Manual Input

Field Type Notes
DAQmx Device
Name

Required Manual Input Set during mode selection on program
start. Can be modified here.

Active DAQ
Channels

Required Manual Input
Setting the DAQ board to access only the
channels to be used; increases the
maximum sampling rate of the system.

DAQ Gain
Required Manual Input Default = 1. Options: 1, 2, 10.

Input Voltage Indicator DAQ Gain setting establishes the input
voltage range.
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Analysis Configuration

Relationships between RPM, Points per Revolution, number of sensing channels, and DAQ sample
rate have an important impact on the measurement process. Settings in this configuration panel
control those relationships. For a more detailed discussion of these relationships, see Appendix C
(page 32).

A sufficient number of samples per revolution is required to obtain a meaningful view of spindle
behavior. However, if the DAQ sample rate is too high, the system can become burdened with
processing the samples and displaying them on the screen, resulting in slow responses to user
input. A meter on the left side of the panel indicates the computer responsiveness with current
settings. If too many samples need to be processed, the meter will move toward “Slow Response.”

Mode Slider

The slider at the top of the panel selects the mode used to determine the DAQ sample rate: Enter
RPM, Enter DAQ Rate, Encoder.

Enter RPM (recommended): the user enters the target spindle speed (RPM) and the Points per
Revolution; the DAQ sample rate is calculated and displayed in corresponding indicators. If the
spindle is currently rotating, the current measured RPM is displayed and can be automatically
entered as the RPM by clicking the arrow button beneath the Measured RPM indicator.

Enter DAQ Rate: the user directly enters the DAQ samples per channel per second.

Encoder: an encoder connected to the spindle is used to trigger DAQ samples.

Enter RPM
Field Type Notes

Target RPM Required Manual Input
RPM used to calculate the DAQ sample rate
based on current setting of Points per
Revolution Enter RPM mode only

Set Target RPM
to Meas RPM

Button Transfers the current measured RPM to the
Target RPM field.

Measured RPM Indicator Current measurement of RPM

Enter DAQ Rate
Field Type Notes

Samp/ch/sec

Indicator (RPM, Encoder
modes)

Indicates the samples per channel per
second based on current RPM and Points
per Revolution settings

Required Manual Input
(Enter DAQ Rate mode)

Sets the number of samples per channel
per second taken by the data acquisition
system Minimum: 1; Maximum: 1,000,000

Channels Indicator Number of channels currently being sampled

Tot Samp/Sec Indicator Total number of samples per second taken
by the data acquisition system
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Encoder
Field Type Notes

Encoder Pulses
per Rev

Required Manual Input
(Encoder mode)

Number of encoder pulses generated per
revolution

Inactive (RPM, DAQ
modes)

Channels Indicator

Divides the encoder pulses per rev to
determine DAQ sample rate. For example,
a 1024 pulses per rev encoder can be
divided by 4 to obtain 256 DAQ samples
per rev.
The result of the division must be an
integer. Any fractional results will cause
each successive revolution to rotate its
position on the plot.

Enter RPM
Field Type Notes

Revolutions for
Display and
Calculations

Required Manual Input
Number of revolutions displayed in test
panels and used for calculated values
Minimum: 1; Maximum: 1,000

Data Points
Displayed per
Revolution

Required Manual Input
(RPM and DAQ modes)

Number of individual points displayed
during each revolution
Minimum:1; Maximum: 5,000

Indicator (Encoder mode) Number of individual points displayed
during each revolution

Maximum RPM Indicator Maximum RPM at which measurements can
be made with current settings

Minimum RPM Indicator Minimum RPM at which measurements can
be made with current settings

Rotation Angle
Detector Required Manual Input

Default = Target Eccentricity Ch. X
Target eccentricity is used to determine the
angular location of the spindle.
Alternatively, an index pulse from a spindle
encoder or other “once around” sensor can
be used.

File Size Selector Required Manual Input

Saved data files can be used for analysis at
a later time. The file size determines the
level of analysis possible. FFT analysis
requires large amounts of data. If FFT
analysis will not be performed later on the
file, a smaller file size is possible. “Small”
file size saves less data so decimation is
not required during processing. See
Appendix C (p. 32 ) for a discussion of
decimation.
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SAVE Config and Restart DAQ Button

Any changes in the DAQ sample rate require a restart of the DAQ system. Click the button to save
the current configuration and restart the DAQ with the new settings.

Calibration Configuration

Calibration information is acquired through TEDS (Elite Systems) or VTEDS (older sensor
systems). This is automated and these values should not be changed except in the rarest of
circumstances.

The Low/High Sensitivity switch is used to remotely change a sensing channel’s sensitivity. The
Sensitivity switches on the driver front panel are disabled when the sensing system is connected
to the SEA data acquisition system. The sensitivity switch is only applicable to CPL290 and DMT22
drivers.

Field Type Notes

Sensitivity Switch Required Manual Input Only works with CPL290 and DMT22 drivers.

New Gap Indicator
The minimum calibrated distance from
probe face to target, listed in dimensional
units and corresponding output voltage.

Far Gap Indicator
The maximum calibrated distance from
probe face to target, listed in dimensional
units and corresponding output voltage.

Sensitivity Indicator
The amount of output voltage change for a
given change in probe/target gap. This is
calculated from the Near and Far Gap
information.

DAQ Card Range
and Resolution Indicator

Actual near and far gaps after allowing for
DAQ Gain setting. For example, a DAQ Gain
of 10 will give higher resolution, but input
voltage range (and therefore the
measurement range) will be limited to less
than the calibrated range of the sensors.
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Calibration Data

This panel displays the calibration information for all of the sensor channels in the sensor system.
The panels will appear slightly different for Elite Series sensor systems than they do for older
model modular systems.

See the TEDS and VTEDS section below for important detailed information on the functional
differences in the two system types.

Field Type Notes

Reload Button Re-acquires the calibration information
from the TEDS or VTEDS source.

Chassis Indicator
Indicates the connected system type:
“Elite” for Elite Series which uses TEDS, or
“Modular” for the CB-7 cabinet (black and
gray) which uses VTEDS

Available Slots Indicator Number of slots available in the system
enclosure

VTEDS Filename Required Manual Input
Non-Elite systems only

Default filenames follow SEA conventions
and should not require changing. Should a
different filename be necessary, click each
filename to specify the desired VTEDS file.

Columnar Data Indicators A column for each slot indicates the vital
statistics of the sensing channel.

More Button

The “More” button will open a dialog box
with indicators detailing calibration
information acquired from TEDS or VTEDS.
It is possible to change these values but
this should only be done in the rarest of
circumstances and with assistance from
Lion Precision. Any manual changes made
here will be lost when the SEA 8 program is
closed.
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TEDS and VTEDS

TEDS (Transducer Electronic Data Sheet) is technology which enables measurement systems to
acquire a wealth of calibration information directly from the sensor. SEA 8 depends heavily on
TEDS for configuration information.

The Elite Series is TEDS compliant and provides configuration information to SEA 8 when the
software is launched. Older “modular” systems (black and gray enclosures) are not TEDS
compliant and do not provide the configuration data directly. When SEA 8 is used with older
sensing systems, the required TEDS data is provided through VTEDS files (Virtual TEDS). These
files are provided on a CD and contain specific calibration information for the system being used.

It is critical that the correct VTEDS files be used with the corresponding sensing system.

The VTEDS CD includes an installation program which will install the files in the appropriate folder
of the SEA 8 system, provided SEA 8 was installed in default directories. The VTEDS files must be
located in the “VTEDS Files” subdirectory of the “Program Data” directory. The “Program Data”
directory may not be visible in Windows 7. For instructions on changing this, see Making Program
Data Folder Visible in Windows 7 in the appendices (page 32).

Machine Information

Optional, machine-specific information can be entered here including spindle position information
on six axes.

Field Type Notes

Operator Name Optional Manual Input Value is displayed as part of “time stamp”

Machine ID Optional Manual Input Value is displayed as part of “time stamp”

Position/Units Optional Manual Input
Position settings in six axes and unit of
measure. Three of the six axes can be
displayed in degrees as well as inches or
meters

Graphic File Optional Manual Input
Click the existing image to load a photo or
drawing to represent the machine under
test. Possible graphic file types: bmp, pcx,
wmf.
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The size, shape, and accuracy of the targets affect the measurement results. For maximum
accuracy, the details of the target must be entered here. Each channel of measurement can have
separate values.

Diagnostics

Various status and condition monitors are available in this panel. This information may be used
during troubleshooting.

Field Type Notes

Target Model Optional Manual Input Target Model such as “1” Dual Ball”

Target Serial Optional Manual Input Target serial number

Last Cal. Optional Manual Input Last calibration date of the target

Next Cal. Optional Manual Input Target calibration due date

Length X to X2 Required Manual Input

Default = 76.2mm.
Distance between the X and X2 probes.
Used in tilt measurements. Standard 5-
probe nest distance is 76.2mm.

Roundness Error Required Manual Input

Default = 0.0 μm. Roundness error
specification from target calibration
information. This can be entered in either
micron or micro-inch fields.
This value is for reference only and is not
used in calculations.

Target Shape Required Manual Input Default = Sphere

Target Dimension Required Manual Input Default = 25.4mm. Diameter of a round
target.

Target Multiplier Required Manual/
Automatic Input

Sensors are calibrated to flat targets. When
the probes are measuring a cylindrical or
spherical target, a correction multiplier is
required for accurate measurements. When
“Auto” is checked, the multiplier is
automatically calculated for the selected
target shape, size, and calibrated range.
Auto values are only available for probes
with “C” “D” and “2.0” size sensing areas
(i.e. C8-2.0). If an unlisted target or other
sensing area is used, a manual multiplier
can be entered by unchecking the Auto
check box.
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MAKING MEASUREMENTS AND READING PLOTS
Understanding and Interacting with Plots

Adjusting Plot Displays

Scaling

Use the Scaling menu to select Auto or Manual scaling. Auto scaling adjusts to provide the best
view of the existing data. Select Scaling > Manual > Increase or Decrease, or use Page Up and
Page Down keys to adjust scaling manually.

Polar Plots

Polar plots chart measurements at successive
angular locations of the spindle. By default, all
acquire rotations are displayed simultaneously.

The plot scale is listed at the bottom of the plot.

The center of the plot does not represent zero when
the axes do not cross (see example at right). This
allows sufficient display resolution of small spindle
motions, which would be off-screen if the center
were zero.

Calculated values are to the left of the plot.
Definitions of the calculated values are in the
glossary in this manual and in Help.

Calculated Circles

Circles can be displayed on the plots to assist in measuring and viewing some important calculated
values. To enable circle displays, select View > Circles.

Total – Displays two blue circles. The origin of the circles is at the center of the plot. The inner
circle is the largest diameter possible inside of the data points (maximum inscribed circle). The
outer circle is the smallest diameter possible outside the data points (minimum circumscribed
circle). The distance between the circumferences of these circles is the total error motion.

Average – The average circle is not actually a circle. This green curve is generated by placing a
data point at each angular location. The position of the point is equal to the average of the
measurements of all the acquired revolutions at that angular location.

Least Squares – Displays a black circle based on a best-fit, least squares calculation of all the
displayed data points.

To find the center of polar plot data, SEA uses the MLS (Modified Least Squares) method describe
in A Few Methods for Fitting Circles to Data by Umback and Jones (IEEE Transactions on
Instrumentation and Measurement, V52, I6, December 2003).

Plot Scale
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Setup for Making Measurements

Configuration

Scaling

The SEA 8 software must be properly configured. Much of the configuration information is
accessed directly from the sensing system.

Some configuration information must be entered by the user. This information must be properly
entered for accurate measurements.

See the Configuration section of this manual for details (p. 8).

Connection to the PC

Connect a 68 pin, high-density cable between the rear panel of the capacitive sensing system and
the National Instruments data acquisition system. Connect a USB cable between the USB-6251
DAQ Module and a USB V2.0 (high speed) port on the PC. The USB V2.0 (high speed) port is
necessary due to the high data transfer rates required.

Mounting Probes and Targets

Care and Safety

Each target type has a maximum rotational speed. High-speed rotation can create substantial
energy, and masterballs adjusted with significant runout will by definition be out of balance. Care
must be taken to protect operators when rotating out of balance parts at higher speeds. Guarding
is recommended. Positioning the probe nest such that it is between the operator and the spinning
target will provide some degree of protection.

The masterball targets are high precision components that require special care similar to gauge
blocks.

For detailed information, please consult TechNote LT03-0013 Probe Mounts and Master Targets:
Dimensions, Care, and Adjustment available in the Technical Library at www.lionprecision.com.

Mechanical Setup

There are five goals in the mechanical setup:

• Probes never make contact with target during rotation
(incidental contact during setup while the spindle is
stationary is safe)

• Master ball target axes are aligned with probe axes
(balls are centered on the probes)

• Probes are adjusted to the center of their
measurement ranges

• Target eccentricity is adjusted to be greater than the
expected error motions (50 μm typical)

• Probes stay in range during the full rotation of the
spindle

Target Installation

Targets are installed in the tool/part holder of the spindle
to be tested.

Probe/Target
Axis Alignment

Probe/Target
Axis Alignment
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Axis/Channel Relationships

Default settings in the SEA software assume Axis/Channel relationships as listed in the table
below. Some individual tests allow the assignment of other Axis/Channel relationships. This
flexibility allows a three-channel system to make measurements normally requiring five channels,
such as using the Z probe temporarily in the X2-axis to make a Tilt measurement.

Probe Nest

Loosen the clamp screws if necessary and install the probes in the nest. Tighten the probe clamps
such that the probes are held in place but can still be repositioned by hand.

Mount the probe nest such that the rotating target can be moved into range of the probes in the
nest. It is critical to firmly clamp the probe nest to the machine tool table.

Positioning Spindle/Targets and Probes

Each probe must be precisely centered on the spherical surfaces of the targets. Target centers are
located and positioned by using the probes and Probe Meter to find the high-spot as the target is
repositioned in front of the probe. Center the targets on the probe with a process such as this:

Initial setup

1. In any quadrant, select Display > Probe Meter.
2. Maximize the Probe Meter (double right-click on the panel)
3. Move the X-, Y-, and Z-axis probes to a retracted position in the probe nest to prevent

collision with the spindle/target when it is moved into approximate position.
4. Move the spindle/target in the X-and Y-axes to position it in the probe nest approximately

centered on the Z-axis probe.
5. Next, move the spindle/target in the Z-axis to approximately center the masterball on the X-

and Y-axis probes. Z-axis centering of masterballs
6. Select the Z-axis channel on the Probe Meter (usually channel 3).
7. Adjust the Z-axis probe mechanical position until the Near/Far indicator on the driver is in

the center position.
8. While observing the Probe Meter adjust the machine X-axis position until the high-spot

(maximum positive indication) is indicated on the Probe Meter.

Default Axis/Channel Relationships

Axis Channel

X 1

Y 2

Z 3

X2 (X-axis probe near spindle
nose in 5 probe setups) 4

Y2 (Y-axis probe near spindle
nose in 5 probe setups) 5
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9. While observing the Probe Meter adjust the machine Y-axis position until the high-spot
(maximum positive indication) is indicated on the Probe Meter.

10. The target is now centered over the Z-axis probe.
11. Loosen and move the Z-axis probe away from the spindle so it will not be touched during the

following steps.
X/Y-axis centering
12.Select the X channel on the Probe Meter
13. Physically adjust the X-axis probe position until the Near/Far indicator on the respective

driver is in the center position.
14.Adjust the spindle Z-axis position until the high-spot (maximum positive indication) is

indicated on the Probe Meter.
15.Using the Near/Far indicator on each respective channel, adjust the X- and Y-axis probe

positions so they are at the center of range.
Return Z-axis probe to position
16.Select the Z channel on the Probe Meter
17.Readjust the Z-axis probe mechanical position until the Near/Far indicator on the driver is in

the center position.
Measuring/Adjusting Target Eccentricity

Target eccentricity is adjusted to provide a once-around signal that is used to determine angular
location of the spindle. Eccentricity should be slightly higher than the expected error motion (50
μm typical). Eccentricity is not required when using an index pulse.

1. Select an X- or Y-axis probe on the Probe Meter. (If using a dual-ball target and five-probe
nest, first select a probe for the ball nearest the spindle nose).

2. Click Refresh TIR on the Probe Meter.
3. Turn the spindle by hand one rotation.
4. The distance between the TIR markers (sticky needles) is the eccentricity of the target
5. If eccentricity needs adjustment, adjust the target eccentricity according to TechNote LT03-

0013 Probe Mounts and Master Targets: Dimensions, Care, and Adjustment included with the
system and available in the Technical Library at www.lionprecision.com.

6. When the eccentricity is correct, move all probes into center of range as indicated by Near/
Far indicators on the drivers.

7. Rotate the spindle again and monitor the Near/Far indicators on all sensor channels. If any
channel goes out of range (a red light turns on) during the rotation, slightly reposition that
channel’s probe and retry until all probes remain in range during the rotation.

8. Tighten all probe clamps.
9. Rotate spindle again to confirm all probes remain in range.
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Temperature Probes

Place temperature probes as desired on the machine under test. SEA 8 temperature channels T1
– T7 are related to TMP190 sensors as shown in the table below.

Encoder/Index Connections

Refer to the TMP190 manual for connection details. Spindles without encoders may still use an
Index pulse by using an external sensing source such as a mark and an optical sensor.

Pin Numbers Connection Pin Numbers Connection

1,9 Probe 1 (T1) 5, 13 Probe 5 (T5)

2, 10 Probe 2 (T2) 6, 14 Probe 6 (T6)

3, 11 Probe 3 (T3) 7, 15 Probe 7 (T7)

4, 12 Probe 4 (T4) 8 No connectionConnector on
TMP190

1

9

8
15
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RUNNING TESTS

To view live test data while a spindle is being measured, select Load > Live Display from the
SEA 8 main menu bar.

To view data from saved measurement data, select Load > Test Data File.

Reading and interacting with the test plots and panels in general is covered above. The following

sections give specific, unique information about the specific tests.

The default channels are listed first as the Possible Channel Combinations.

Basic Tests

Radial: Rotating Sensitive Direction

X and Y axis measurements are used to create a polar plot using one of two possible methods:

B89.3.4 (r-theta) or

Tlusty

The method is selected by View > Method.

Radial: Fixed Sensitive Direction

Number os Sensors Used 2

Axes Measured {X, Y}

Possible Channel Combinations {1, 2} or {4, 5}

Number os Sensors Used 1

Axes Measured {X} or {Y}

Possible Channel Combinations {1} or {2} or {3} or {4} or {5}

X or Y axis measurements are acquired and presented in a polar plot or a linear plot with angular
position on the X-axis.

Select the plot type with View > Polar Plot or Linear Plot.

Axial Error Motion

Number os Sensors Used 1

Axes Measured {Z}

Possible Channel Combinations {3} or {1} or {2} or {4} or {5}
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Measures spindle motions in the Z-axis using the probe mounted in the bottom of the probe nest.
Polar and linear plots are available (View > Polar or Linear).

Select View > Display to choose one of three different display options are available for the plots:

Total with Fundamental – includes error motions at the rotational frequency
(fundamental) of the spindle.

Total without Fundamental – error motions at the rotational frequency of the spindle
are removed from the data before plotting.

Asynchronous Only – error motions at the fundamental or harmonics of the rotational
frequency are removed before plotting.

The calculated values are not affected by display choice. See the glossary for more information on
these display modes.

Tilt: Fixed Sensitive Direction

Measurements from both X and X2 (or Y and Y2) channels provide measurements of the
synchronous and asynchronous changes in the tilt of the spindle at different angular locations. A
standard polar plot (tilt angle in μradians) or a 3D plot are available.

Because Tilt measurements only require two probes (in the same axis), two or three channel
systems can make Tilt measurements by moving a probe from its original position into the X2 or
Y2 position and using View > Channels to select the probe that was moved.

Plot type is selected with View > Polar or 3D.

Thermal

The two thermal tests listed in international standards are ETVE (Environmental Temperature
Variation Error) which is performed while the spindle is stationary, and Thermal Drift which is
measured when the spindle is rotating. The display and basic operation of the panel remains the
same for both tests. Only the time of the test, the channels used, and the rotation of the spindle
are changed.

During the test, measurements are acquired from all channels enabled in DAQ
Configuration. Any channels (displacement or thermal) that are not enabled in DAQ
Configuration, will not record during thermal tests.

Setup

The thermal test setup parameters are accessed by clicking Setup! on the Thermal menu bar. In
the Setup dialog box:

▪ Select test type:
◦ Rotating (Drift Test; usually short duration; 1 hour typical)
◦ Non-Rotating (ETVE; long duration; 24 hours typical)

Number os Sensors Used 2

Axes Measured {X, X2} or {Y, Y2}

Possible Channel Combinations {1, 4} or {2, 5} or {1, 2} or {1, 3}

Number os Sensors Used 1-5, plus up to 7 temperature sensors

Possible Channel Combinations Any single channel or tilt combinations (and up
to seven temperature sensors)

CAUTION
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▪ Set test duration (Hours, Minutes):
◦ Sampling frequency is 2 sec/sample for test of 4 hours or less, and 10 sec/sample for

tests of more than 4 hours. The sampling frequency is displayed below the duration
fields.

Select a file name for data storage

Chart Time Axis

When a test is started, the chart will begin showing a five minute period so that early
measurements are easily seen. After five minutes, the display will shift to show the total test
duration.

Channel Select Buttons/Displays

Clicking Sensor buttons enables/disables the display of that channel on the chart. When clicked,
the X2 and Y2 buttons rotate through Drift/Tilt/Disabled options. The Redraw button must be
clicked to display newly enabled/disabled selections.

The value displayed on the buttons is the Range of measurements taken (max-min) for that
channel during the test.

Custom Temperature Channel Names

Right-click on a temperature channel button to enter a custom name such as “ambient” or
“spindle.”

Shift vs. RPM

The axis of rotation of the spindle may change location with changes in RPM. The test charts
changes in the position of the axis of rotation of the spindle against RPM. The operator adjusts
RPM and clicks the Save Point button to plot a point.

The first time Save Point is clicked, measurements of the spindle in all axes are set as the
reference for future measurements. Successive clicks of Save Point will plot the position change
of the spindle at the measured RPM.

Clicking the channel buttons will enable/disable the display of that channel.

Measurements can be taken as the RPM is increased and retaken as the RPM is decreased to
display any hysteresis in the RPM/Spindle Position relationship.

Donaldson Reversal

Donaldson Reversal displays data from two Radial – Fixed Sensitive test runs combined in such a
way that form errors in the target (out of roundness) are separated from the synchronous error
motion of the spindle. The Radial – Fixed Sensitive display must be active in another quadrant
during Donaldson Reversal functions.

Number os Sensors Used 1-5

Axes Measured Any

Possible Channel Combinations All single channels or tilt combinations
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First measurement:

1. Display the Donaldson Reversal panel in one quadrant.
2. Display Radial – Fixed Sensitive panel in another quadrant.
3. Perform a Radial – Fixed Sensitive measurement.
4. Click Store A to store the current Radial – Fixed Sensitive plot in the Donaldson Reversal

display.
5. Stop the spindle.

Second measurement

6. Move the probe to a position 180° around the spindle from its original position.
7. Remove and replace the target 180° from its original position in the spindle.
8. Perform another Radial – Fixed Sensitive measurement (do not change any settings).
9. Click Store B to store the new Radial – Fixed Sensitive plot in the Donaldson Reversal

display.
10.Click Calculate.

The synchronous error motion of the target and the spindle are plotted independently. Use the
display buttons to turn individual plots on and off.

Automated Measurement

Automated Measurement is useful for testing time- or speed-related changes in spindle
performance. Multiple trials of a spindle test are automatically repeated and recorded based on
time intervals or changes in RPM. Three types of tests can be performed with Automated
Measurement:

▪ Radial – Rotating Sensitive Direction
▪ Radial – Fixed Sensitive Direction
▪ Axial

The selected test must be active and configured in another quadrant on the screen.

Click Setup! on the menu bar to configure the test.

Test Type

Choose which of the three tests to run.

File Name

Select a file name and location for data storage

A slider-type control selects Time or RPM for the automated measurements.

Trial and Group Setup (Time-Based Measurements)
Time-Based Measurements repeatedly run the selected test at a specified time interval. Each run
of the test is called a Trial and fills one row in the data file. Multiple trials can be grouped. A
Group consists of 1 to 1000 trials. Time intervals between Trials and Groups can be set
independently. Test runs can include 1 to 1000 Groups. Use caution with large Trial and Group
sizes as the data file can become very large.
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Trials/group

Set the number of trials to run per group. 1-1000

Group

Set the number of Groups to run during the test. 1-1000

Total Trials

This is a calculated field of the total number of tests that will be performed and recorded in the
data file. Large numbers of Total Trials will create very large data files and should be avoided.

RPM-Based Measurements

Auto RPM automates testing at different spindle speeds. Operators can increase spindle speed,
manually or programmatically, and SEA will automatically initiate a measurement at specified
speeds.

Auto RPM assumes that RPM will increase during the automated test. After taking a
measurement at the Stop RPM, testing will cease.

Start RPM: lowest RPM at which to measure

Stop RPM: highest RPM at which to measure

Step RPM: intervals at which to measure

RPM Window: error margin for RPM measurement. RPM must fall within the window to trigger

a measurement

Dwell Time: delay after achieving an RPM before measurements are made

DAQ Reset Disabled: this warning appears if the DAQ sample rate mode is not set to Entered
RPM in the Analysis Configuration ( page 9). Entered RPM is the best mode for RPM based
automated testing as it will maintain a consistent number of samples/revolution through all of
the tested speeds.

Limits

Under some circumstances, values reported by SEA, especially RPM, may momentarily report
aberrant values such as 0 or 1 RPM. This is due to system processor limitations. In normal
operation, the operator rarely notices these quick, momentary values, but should it occur while
the Automated Measurements is collecting data, the resulting data would be skewed.

Check the parameters to be monitored and set minimum and maximum values. Automated
Measurements will verify that all checked values are within limits before capturing the data. If any
checked values are outside the limits, the system will wait until all values return are within limits
before executing the test. While waiting, the system will display a red Beyond Limits message in
the table.

Trial Delay

The time in seconds between the starts of
each trial.

Group Delay

The time in seconds between the starts of
each group.

Group Delay must be longer than

Trial Delay X Number of Trials. See figure.

TrialDelay
Group Delay

T1 T2 T3 T4 T5 T1 T2 T3 T4 T5
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When all selections have been made, click START Test. The test will run until the selected number
of Trials and Groups have been completed. The test can be paused or ended before completion by
clicking the appropriate button.

View > Automated Test File loads a previously saved test file for viewing.

Used to analyze frequency distributions in error motions. The FFT analysis test acquires sampled
amplitude data from a single probe in the time domain and converts the data into the frequency
domain. A graph of amplitude vs. frequency is produced. The graph is updated once per second,
showing the FFT results on the most recent data set.

FFT Views (from View menu):

Bar Graph – Bar (column) graph display

Line Graph – Continuous line connecting measurements

Ping – Plots the results of a triggering event such as a hammer ping.

Window(from View menu):

Selects the type of mathematical windowing technique for displaying the FFT. Hanning or
Rectangular are typical choices.

Scaling

Scaling and axis units, as well as FFT size options are available in the Scaling menu. Cursor

A cursor (View > Show Cursor Values) can be used display values at any point on the charts
X- axis (frequency). Click and drag the mouse pointer to reposition the cursor or use keyboard
arrow keys. For fine adjustment, hold the shift key while using arrow keys.

Note: Collecting FFT Data Can Take A Long Time

64K FFT analysis (largest available size) from a saved file requires that more than 65,000 samples
be saved. At lower RPMs and lower sample rates, this can take considerable time. For example, at
150 RPM and a sample rate of 100 points per revolution, 4.3 minutes (260 seconds) will be
required to collect 65,000 samples. If FFT analysis will be done on the saved file, be sure to
observe the FFT screen after starting the test and be sure the display has stabilized before saving
the file.

Oscilloscope

The Oscilloscope is a utility display that emulates a basic oscilloscope, allowing a time based view
of the data acquired on any of the five probe channels.

Use the View menu to select DC or AC Coupling.

FFT Frequency Analysis

UTILITIES

Number os Sensors Used 1

Axes Measured Any

Possible Channel Combinations All single channel
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Probe Meter

The Probe Meter is a utility display that emulates an analog meter indicating the current probe/
target gap of the selected probe.

The Probe Meter is best used maximized to full screen.

Any one of the five probe channels can be displayed. Use the mouse or the up or down keyboard
arrows to select a different channel.

If the measurement is out of range, red “overrange” text will appear on the meter.

Maximum and minimum indicators retain the maximum and minimum positions of the meter
needle. These values are shown digitally below the meter. Click the Refresh TIR button to reset
the maximum and minimum indicators to the current meter indication.

Saving and Printing Results

Positioning the mouse cursor over Save on the main menu will pause the acquisition process. This
provides a stable display for screen printing, saving, or on-screen visual analysis. Saving files from
the main menu bar saves rotating test data into a “.lda” file. File size can be from 1-20MB
depending on sample rates and other factors.

Thermal, Shift vs. RPM, Automated Test, and Donaldson Reversal test files are only saved from
their corresponding quadrant windows.

Clicking Save will launch the Save dialog box and copy a screenshot to the clipboard. The user
enters a file name into which the data will be saved. SEA can optionally append a counter to the
end of the file name allowing for automatic increments to the file name during subsequent saves.

Note: Collecting FFT Data Can Take A Long Time

64K FFT analysis (largest available size) from a saved file requires that more than 65,000 samples
be saved. At lower RPMs and lower sample rates, this can take considerable time. For example, at
150 RPM and a sample rate of 100 points per revolution, 4.3 minutes (260 seconds) will be
required to collect 65,000 samples. If FFT analysis will be done on the saved file, be sure to
observe the FFT screen after starting the test and be sure the display has stabilized before saving
the file.

Core File Name: the file name and path into which data is saved (i.e. c:\machinedata.lda).

File Name to be saved: If Auto Increment is not selected, the field is not visible. If Auto
Increment is selected, the Core File Name is amended with an underscore and automatically
incrementing file number (c:\machinedata_1.lda). The final resulting file name is displayed here.

Selectable Options:

Save data file: saves current data represented on screen to the file name indicated

Save screen image: saves a screenshot to the same file name but with .bmp extension

Print screen image: prints the screen to the default printer after the save operation

Auto increment...: enables the automatic incrementing of file name
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File Structure

Critical files for SEA must be located in appropriate subdirectories. These files are placed in the
correct locations during the installation process. This structure is provided in case new files need
to be added or to assist in troubleshooting.

base = C:\Program Files\SEA8

Contains all program files

base \DOCS

All Help files

SEA 8.0 Manual

Related documents and text files

C:\ProgramData\LionPrecision\SEA8\VTEDS Files

VTEDS files must be in this subdirectory to be used by SEA 8

C:\ProgramData\LionPrecision\SEA8\Data

Default directory for data files. User can save data files to any location. All sample data
files

SEA 8 measurement data files can be stored anywhere

C:\ProgramData\LionPrecision\SEA8\Setup

All configuration files

C:\ProgramData\LionPrecision\SEA8\Language

Text files with labels and phrases used in SEA 8, translated to the language of the name of
the file, e.g. english.txt contains the English labels and phrases.
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APPENDICES
A: Menu item descriptions

Main Menu Bar

Save

Placing the cursor over Save on the main menu bar will pause the acquisition process.

Clicking Save copies a screenshot to the clipboard and launches a dialog box with file save and
print options. If a screenshot is all that is necessary, the dialog box can be cancelled. See p. 26
for details.

Load

Live Display: purges all data buffers then starts or restarts the Data Acquisition device and
begins to display data in each of the four quadrants. The source indicator in each quadrant
changes to indicate Live Data.

Test Data File: (*.lda) – Data is displayed in all radial and axial panels

Thermal Data File: (*.lts) – Data is displayed in the Thermal panel only

Donaldson Reversal File: (*.trv) – Data is displayed in the Donaldson reversal panel only

Automated Test File: (*.lsq) – Data is displayed in the Automated Test panel only

Viewing stored data loads the original configuration file. The configuration settings cannot be
changed.

Configuration

Show: loads all quadrants with configuration panels; General, DAQ, Diagnostics, Calibration

Save Configuration: saves the current configuration.

Configure As (new file): “save as” function for creating new configuration file

Load Configuration: loads existing configuration file

Return to Test Displays: removes configuration screens from quadrants and reloads test panels
DAQ Rate!

This menu item is only available when the Analysis Configuration is set to “Entered RPM.” Selecting
this item will immediately calculate new DAQ sample frequencies based on the current RPM and
restart the DAQ at the new settings. This is useful when doing tests at different spindle speeds.

Help

Manual starts Windows Help with an electronic copy of this manual.

Typical Setups displays a photo of a typical setup for the selected machine type.

Lion Precision Support lists contact information for Lion Precision technical support About gives
version information for SEA 8

Exit!

Closes the program.
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Quadrant Menus

Quadrant menus will contain different options depending on what the quadrant is displaying. All
possible menu items are listed below, but they will not all appear on every quadrant.

Display

Lists all possible quadrant displays. All Test and Configuration displays can be accessed through
this menu. Whether the quadrant is currently a Test or Configuration display changes the
groupings in this menu.

View

View > Maximum Size enlarges a quadrant panel to full screen.

View > Normal Size reduces a full-screen panel to a quadrant.

View > Polar Plot provides a polar plot of the error motion.

View > Linear Plot provides a linear plot of the error motion with degrees of rotation as the
chart’s X-axis and error as the chart’s Y-axis.

View > Display > Total displays the synchronous plus asynchronous error.

View > Display > Total with Fundamental displays all spindle motions including motions
occurring at the rotational speed of the spindle.

View > Display > Total without Fundamental removes motions occurring at the rotational
speed of the spindle.

View > Display > Asynchronous Only displays the asynchronous error only.

View > Circles > Total [F3] draws the maximum and minimum value circles on the graph. View
> Circles > Average [F4] draws the average value plot on the graph.

View > Circles > Least Squares [F5] draws the least squares circle on the graph.

View > Revolutions > Individual [F6] causes the display to pause the current data and display
the first revolution. While the display is paused, changes in the live data will not be seen on the
display. Subsequent selections of this menu item will display subsequent revolutions. The
displayed revolution number is indicated in the lower right of the graph.

View > Revolutions > Choice [F9] selects up to three revolutions for display. This allows non-
consecutive revolutions to be displayed simultaneously in three different colors.

View > Revolutions > All [ESC] displays all the revolutions. The display is still paused and the
revolutions displayed are the same as those shown in the individual selections.

View > Channel allows the selection of X, Y, Z, X2, or Y2. X is the default. Selecting other
channels is only meaningful if probes are connected to those channels and channels are enabled
in DAQ Configuration.

Setup!

Some tests require specific setup information not included in the configuration screens. Clicking
the Setup! menu item immediately displays a dialog box for setting test parameters.

Scaling

Scaling > Rescale [Enter] when in manual scaling mode scales the current data to fit the plot
area.

Scaling > Auto [End] monitors the data and changes the scale so that the data is always
within 40% to 90% of the scale. Auto-scaling can also be activated by clicking the END key
while the quadrant is active.

Scaling > Manual > Increase [PgUp] or Decrease [PgDn] deactivates auto-scaling and
increases or decreases the graph scale.
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B: Supported DAQ Hardware

Only the USB-6251 is supported by SEA 8.5.

SEA 8 uses DAQmx and can query the DAQ module for gain and sample rate information;
however, many DAQ modules do not support these functions. As a result, many other DAQ
modules may work but are not guaranteed by Lion Precision.

If requested sample rates exceed hardware maximums, the sample rate will be adjusted to the
maximum the hardware can support, and a message will be displayed stating the change in rate.

If the USB-6251 fails to start

Confirm that the correct Device Name is entered in the “DAQmx Device Name” entry in
the DAQ Setup screen. Only available module names will appear on the pull-down menu
for the “DAQmx Device Name” control. When a device is selected, its model name will
appear below the control. Confirm that the model name matches the expected name.

If problems persist:,

1. Exit SEA

2. Start National Instruments “Measurement and Automation Explorer”

3. Select “NI-DAQmx Devices and Interfaces”

4. An entry similar to NI USB-6251: “Dev1” will appear

5. The value in quote marks in this example “Dev1” is the device name for your device. If you
have multiple devices installed, each one will appear with its own device name. Select the device
name for the device you wish to use.

If problems still persist, start by entering a very low sample rate such as 1000 to verify basic
functionality.

The user must confirm the accuracy of data acquired with any other DAQ device.CAUTION
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C: Relationships Between Sample Rate, RPM, Points Per Revolution, and Revolutions to
Display

Depending on configuration settings in the Analysis Configuration window, the Spindle Error
Analyzer can be asked to handle very large amounts of data. Some of the configuration settings
have maximum allowed values, but other variables and buffers in the system are determined by
multiplying some of these settings together. These products may exceed the maximum sizes of
system buffers even though the individual variables are within limits. For those that are using SEA
near its maximum limits, this detailed discussion of the data acquisition, processing, and display
functions will help avoid any errors from exceeding maximum allowed values and buffer sizes for
process variables that are not directly set in the configuration screens.

Please refer to the block diagram below.

Understanding Points Per Revolution and Sample Rate

Users set the Points Per Revolution to be measured and displayed. In an ideal world, precisely that
number of samples would be taken during each rotation of the spindle. In the real world, the
Points Per Revolution is only a close approximation of what will actually happen. The sample rate
of the DAQ system is set when a test begins. Because the sample rate is fixed in time (not
rotations), any changes in RPM result in a different number of actual samples per revolution.
Changing the sample rate of the DAQ system would require stopping the test, stopping the DAQ
system, reprogramming the new sample rate and restarting the DAQ system.

To allow intentional changes in RPM with a relatively stable Points Per Revolution, a process of
Decimation is used. The Decimation routine eliminates portions of data coming from the DAQ.
This changes the effective sample rate feeding the Test Processing routines without stopping
the DAQ to change the actual sample rate. At its highest setting, the Decimation routine averages
16 measurements to create a single sample. The Decimation value is programmatically adjusted
in real-time to maintain the Points Per Revolution without changing the actual sample rate.

How the Settings Work Together

Number of Channels: The DAQ system can read up to 5 displacement channels (X, Y, Z, X2, Y2
axes), 1 temperature channel (this single channel contains the data of up to seven temperature
sensors), and 1 Index channel. The number of channels enabled in the DAQ configuration plays a
significant role in determining maximum values throughout the system.

Total Sample Rate is the actual rate at which the DAQ system samples the sensors. The Total
Sample Rate is determined differently depending on the Analysis Configuration mode and has a
maximum of 1Ms/S (1Million Samples/Second).

Analysis Configuration Modes:

Entered DAQ Rate Mode: In this mode, the user directly enters the sample rate as
Samples/Channel/Second. That number is then multiplied by the number of active
channels to determine the Total Sample Rate.

Encoder Mode: The spindle encoder output pulses directly drive the DAQ system. Each
pulse from the encoder triggers a “scan” of the DAQ system. A scan is a sequence of one
sample for each active channel. Encoder pulses per revolution may be too high and create
too many displayed points or exceed maximum limits of the system. To prevent this, the

Custom Divider divides encoder output to reduce sampling frequency. The number of
pulses per second from the encoder after the divider [(Pulses per Revolution /Divider) X
(RPM / 60)] must be less than (1M) / (number of channels). The result of the division must
be an integer. For example, a 256 pulse per revolution encoder divided by 3 will result in
85.3. The software will truncate this number to 85, causing measurements for the next
rotation to begin before the rotation is complete. Any fractional results will cause each
successive revolution to rotate its position.
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Entered RPM mode (recommended): Entered RPM mode allows the system to calculate
the optimal sample rate and decimation value based on the entered RPM, the Points per
Rev for the display, and the number of active channels. The calculation uses these
parameters then multiplies the resulting sample rate by 4 and sets the Decimation value
to 1/4. This allows the decimation routines to compensate for increases and decreases in
RPM while maintaining the Points Per Revolution.

After the Total Sample Rate is calculated, the DAQ is programmed with the Total Sample Rate and
the test is started. Resulting data, after any decimation, is fed to the test routines for processing,
storage, and display. Test Processing routines place the test results in the Display Buffer. The
total number of points held in the Display Buffer is (Points per Revolution) X (Revolutions to
Display) to a maximum of 32K. For example, if Points Per Revolution is 1000, then the maximum
possible Revolutions to Display would be 32.

Sensors
Up to:

5 Displacement Channels,
1 Temperature Channel

(includes all temp. sensors),
1 Index Channel

DAQ

Total Sample Rate
Max = 1Ms/S

Decimation
Max = 1/16

Data Buffer
1M/Chan

Test
Processing

Display Buffer
(Pts./Rev.) X (Revs to Display)

32K Max.

Analysis Configuration Modes

Entered
DAQ Rate

(Samples/Chan/Sec)

Encoder
Pulses/Rev.

Entered
RPM

Display

Calculation
(RPM/60) X (Pts./Rev.) X (# Channels) X (4)

Calculation
(Samples/Chan/Sec) X (# Channels)

Calculation
(Pulses/Rev. / Divider) X
(RPM / 60) X (# Channels)
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D: Making the “Program Data” Folder Visible in Windows 7

The “Program Data” folder contains the saved data files which can be viewed and analyzed at a
later time. The folder also contains other data files that may necessary to access for SEA
configuration such as VTEDS files.

The “Program Data” folder is located in the root directory of the disk to which SEA was installed.
Windows 7 automatically creates this as a hidden folder making it inaccessible in the Windows
Explorer and some file select options within SEA.

To make this folder “visible”:

1. Launch Windows Explorer (not Internet Explorer)

2. Click the “Organize” button near the top

3. Select Folder and Search Options

4. In the popup dialog box, click the “View” tab

5. In the option list of the View tab, find the Hidden Files and Folders line

6. Select the “Show hidden files, folders, and drives” button.

7. Click OK
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GLOSSARY
Many of the definitions here are taken from ASME B89.3.4-2010: Axes of Rotation: Methods for
Specifying and Testing.

Asynchronous error motion - the portion of the total error motion that occurs at frequencies
other than integer multiples of the rotation frequency. Asynchronous error motion comprises those
components of error motion that are: (a) not periodic (b)periodic but occur at frequencies other
than the spindle rotational frequency and its integer multiples, (c) periodic at frequencies that are
subharmonics of the spindle rotational frequency.

Asynchronous error motion value - the maximum scaled width of the asynchronous error
motion polar plot, measured along a radial line through polar chart center.

Axial error motion - error motion coaxial with the Z reference axis. Axial slip, end-camming,
pistoning and drunkenness are common but inexact terms for axial error motion.

Axial thermal drift - applicable when the displacement is collinear with the Z reference axis.

Axis average line - a line segment passing through two axially separated radial motion polar
profile centers. The axis average line is used to describe the unambiguous location of an axis of
rotation with respect to the reference coordinate axes, or changes in the location, for example, in
response to changes in load, temperature or speed.

Axis of rotation - a line segment about which rotation occurs

Axis shift – a change in position of the axis of rotation caused by a change in operating
conditions.

Bearing - an element of a spindle that supports the rotor and allows rotation between the rotor
and the stator.

Displacement indicator - a device that measures displacement between two specified objects.

Error motion – changes in position, relative to the reference coordinate axes, of the surface of a
perfect workpiece, as a function of rotation angle, with the workpiece centerline coincident with
the axis of rotation.

Face error motion – the sum of the axial error motion and the axial component of tilt motion at
the specified radius. Face error motion is parallel to the Z reference axis at a specified radial
location. The term “face runout” has an accepted meaning analogous to radial runout and hence
is not equivalent to face error motion.

Face thermal drift - applicable to a combination of axial and tilt displacement measured at a
specified radial location.

Fixed sensitive direction – the sensitive direction is fixed when the workpiece is rotated by the
spindle and the point of machining or measurement is not rotating.

Fundamental error motion - that portion of the total error motion that occurs at the rotational
frequency of the spindle. Fundamental axial and fundamental face motions are error motions and
cause flatness errors on parts. However, fundamental error motion will create a part with the
property of circular flatness: The surface is flat and will provide a “sealing surface” at any given
radius. This unique property is important to the hydraulic industry. Fundamental radial and
fundamental tilt displacements are not error motions because they represent misalignment of the
artifact, not a property of the axis of rotation. Fundamental axial and fundamental face motions
are error motions and have important engineering consequences.
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Fundamental error motion value - twice the scaled distance between the PC center and a
specified polar profile center of the synchronous error motion polar plot. Alternatively defined as
the amplitude of the rotational frequency component. The value is twice the amplitude because,
in this case, amplitude represents the average-to-peak value rather than the peak-to-peak value.
Fundamental axial value and fundamental face value are the same value. There is no fundamental
radial error motion value - in the radial direction, motion that occurs at the rotational frequency
is caused by an off-center reference target and is not a property of the axis of rotation.

Least squares circle (LSC) center - the center of a circle which minimizes the sum of the
squares of a sufficient number of equally spaced radial deviations measured from it to the error
motion polar plot.

Nonsensitive direction - is any direction perpendicular to the sensitive direction.

Perfect spindle - a spindle having no motion of its axis of rotation relative to the reference
coordinate axes.

Perfect workpiece - a rigid body having a perfect surface of revolution about a center line

Radial error motion - error motion in a direction perpendicular to the Z reference axis and at a
specified axial location.

The term “radial runout” has an accepted meaning which includes errors due to centering and
workpiece out-of-roundness and hence is not equivalent to radial error motion.

Radial thermal drift - applicable when the displacement is perpendicular to the Z reference axis.

Residual synchronous error motion - the portion of the axial and face synchronous error
motion that occurs at integer multiples of the rotation frequency other than the fundamental.
Residual synchronous and synchronous error motions are mathematically identical. These type of
errors cause flatness errors on the face of turned parts.

Residual synchronous error motion value-the scaled difference In radii of two concentric
circles from a specified error motion center just sufficient to contain the residual synchronous
error motion polar plot.

Rotating sensitive direction – the sensitive direction is rotating when the workpiece is fixed and
the point of machining or measurement rotates.

Rotor - the rotating element of a spindle.

Runout - the total displacement measured by a displacement indicator sensing against a moving
surface or moved with respect to a fixed surface. The terms “T.I.R.” (total indicator reading) and
“F.I.M.” (full indicator movement) are equivalent to runout. Surfaces have runout; axes of rotation
have error motion. Runout includes errors due to centering and workpiece form errors and hence
is not equivalent to error motion.

Sensitive direction - the sensitive direction is perpendicular to the perfect workpiece surface
through the instantaneous point of machining or measurement

Spindle - a device which provides an axis of rotation. Stator - the stationary element of a spindle.

Stator-to-rotor error motion – generic term for any error motion associated with a spindle
measured between the ends of a minimal structural loop.

Structural error motion - error motion due to internal or external excitation and affected by
elasticity, mass, and damping of the structural loop.

Structural loop - the assembly of components which maintain the relative position between two
specified objects.
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Synchronous error motion - the components of total error motion that occur at integer
multiples of the rotation frequency. The term average error motion is equivalent but no longer
preferred. The method of averaging described in B89.3.4 Fig A11 remains acceptable for the
determination of synchronous error motion.

Synchronous error motion value - the scaled difference in radii of two concentric circles from
a specified error motion center just sufficient to contain the synchronous error motion polar plot.

Thermal drift - a changing distance or angle between two objects associated with a changing
temperature distribution within the structural loop.

Thermal drift plot - a time-based record of thermal drift.

Thermal drift value - the difference between the maximum and minimum values over a

specified period of time and under specified conditions.

Tilt error motion - error motion in an angular direction relative to the Z reference axis.

Coning, wobble, swash, tumbling and towering errors are common but inexact terms for tilt
error motion.

Tilt thermal drift - applicable to a tilt displacement relative to the Z reference axis. Total
error motion - the complete error motion as recorded.

Total error motion value - the scaled difference in radii of two concentric circles from a
specified error motion center just sufficient to contain the total error motion polar plot.
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SOFTWARE LICENSE AGREEMENT
By receipt and use of this LION PRECISION product you, the end user, and LION PRECISION agree
to and are bound by the terms of this license agreement. If the terms of the agreement are not
acceptable to you, return the product to LION PRECISION for full credit. The terms of the
agreement are as follows:

1. GRANT OF LICENSE. In consideration of payment of license fee, which is a part of the purchase
price of this product Lion Precision grants you, the LICENSEE, nonexclusive rights to use the
included Lion Precision software on a single computer at any one moment in time.

2. OWNERSHIP OF SOFTWARE. As the LICENSEE, you own the media upon which any Lion
Precision software is stored but Lion Precision retains title and ownership of the software recorded
on the original media as well as all subsequent copies of the software. This license IS NOT a sale
of the original software. Only the right to use it.

3. COPY RESTRICTIONS. This software and the accompanying written materials are copyrighted.
Unauthorized copying or modifying of this software is strictly forbidden. You may be held legally
responsible for any copyright infringement or encouraged by your failure to abide by this
agreement. Subject to these restrictions, the LICENSEE may make two (2) copies for backup
purposes only. LICENSEE takes full responsibility for the use, and or any distribution of, any copied
software according to this license agreement.

4. USE RESTRICTION. As the LICENSEE you may transfer the software from one computer to
another, provided the software is used on only one computer at any one time. You may not
electronically transfer the software over any network or bulletin board service. You may not
distribute this software or accompanying written materials to others. You may not modify,
translate, reverse engineer, decompile, or disassemble the software.

5. UPDATE POLICY. Lion Precision may create, from time to time, updated versions of the
software. At its option, Lion Precision will make such updates available to the LICENSEE.
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